Using ' in a string

I am using a button dropdown to set a variable; the entries are loaded from a table column. The variable needs to be a string, therefore the wrapping character is '. The problem is that one of the entries in the button dropdown contains an apostrophe (eg John’s) and therefore when it is selected it doesn’t work, giving the error that it is not a valid PQL statement. I tried doubling or tripling the apostrophe but no luck. Is there any way to stop this from happening?

Hello Ale,

welcome to the Celonis Community!

Have you tried to use the “Escape wrapping characters within values”-option in the button dropdown?

image

Best
David

Hello,

Just a followup to this, what if you’re storing a list of strings in a variable and the escape wrapping characters isn’t an option?

For instance, I would like to store ‘Hold for sender - PCP doesn’t match payer’ (along with a bunch of other ‘Hold for sender - reasons’ as the variable <%= hfs_reasons %> . How can I get around this error?

Thanks,
Zach

I tried using that and solved my problem. I hadn’t seen that option in the button dropdown. Many thanks!